Won't start in gear - BMW G310 R/GS Forum
 1Likes
  • 1 Post By Kris
 
LinkBack Thread Tools
post #1 of 10 (permalink) Old 02-14-2019, 05:46 AM Thread Starter
Junior Member
 
Join Date: Jan 2019
Posts: 28
Won't start in gear

It seems easy to stall the engine when it's not in the correct gear or enough throttle. No big deal. But i find it hard to restart the engine when it's in gear and i have the clutch pulled in. I need to find neutral in order to start it. Any idea what the problem may be with the clutch lever sensor and how i can fix it?
JPKenya is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 02-14-2019, 06:55 AM
Senior Member
 
Kris's Avatar
 
Join Date: Dec 2018
Location: India
Posts: 676
Quote:
Originally Posted by JPKenya View Post
It seems easy to stall the engine when it's not in the correct gear or enough throttle. No big deal. But i find it hard to restart the engine when it's in gear and i have the clutch pulled in. I need to find neutral in order to start it. Any idea what the problem may be with the clutch lever sensor and how i can fix it?
the clutch lever sensor is probably broken. you need to make the dealer fix it. i personally am going to install a different clutch system with universal two pins clutch sensor to fit short levers and no needing to worry about all that stuff. i already changed the brake side.

you might also want to try to tighten the lever travel, as if too loose, it is not reaching the switch sensor... actually, this should not have influence on the switch, now that I think of it.
JPKenya likes this.

as you love riding, you need to love you bike

Last edited by Kris; 02-14-2019 at 06:57 AM.
Kris is offline  
post #3 of 10 (permalink) Old 02-14-2019, 01:55 PM
Member
 
Join Date: Oct 2017
Location: Edmonton, Alberta Canada
Posts: 63
A loose clutch cable can cause hard starting while in gear due to clutch drag. If it doesn't crank over at all then the switch is the problem.
oldtimer.ca is offline  
post #4 of 10 (permalink) Old 02-20-2019, 08:25 PM
JMS
Junior Member
 
Join Date: Nov 2018
Posts: 1
Does it have anything to do with the kick stand cut off?
JMS is offline  
post #5 of 10 (permalink) Old 02-20-2019, 10:06 PM
Senior Member
 
Join Date: Apr 2018
Location: Coastal Georgia USA
Posts: 150
Do you have non-stock clutch lever? Otherwise bad switch 99 and 44/100s certain;

Bob

2018 G310R Strato Blue
Old and Slow is offline  
post #6 of 10 (permalink) Old 08-01-2019, 05:57 AM
Senior Member
 
Join Date: May 2017
Posts: 123
you solved? NOW i have the same problem, happens randomly
XRaiders is online now  
post #7 of 10 (permalink) Old 08-01-2019, 02:47 PM
Senior Member
 
Join Date: Mar 2019
Posts: 170
For you guys who are having this problem, did you recently installed an aftermarket clutch lever?
That's the problem but an easy fix.

I had the same problem. Search for one of my previous discussions on this. Someone showed me how to fix this issue. No need to send it to BMW.
NIKITAUCLA is offline  
post #8 of 10 (permalink) Old 08-01-2019, 02:50 PM
Senior Member
 
Join Date: May 2017
Posts: 123
Installed new china levers from one year but problem is from 2 week!
XRaiders is online now  
post #9 of 10 (permalink) Old 08-01-2019, 05:22 PM
Senior Member
 
Join Date: May 2017
Posts: 123
nothing to do I disassembled the microswitch from the clutch lever and pressed with my hand, the engine don't start
XRaiders is online now  
post #10 of 10 (permalink) Old 08-01-2019, 09:04 PM
Super Moderator
 
porth's Avatar
 
Join Date: May 2017
Location: Brisbane Australia
Posts: 821
Garage
Quote:
Originally Posted by XRaiders View Post
nothing to do I disassembled the microswitch from the clutch lever and pressed with my hand, the engine don't start
Ok, just saw this post, as mentioned in my other post, refit your original clutch lever and take to the dealer to fix under warranty.
porth is online now  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting with gear engaged GirlPower Engines and Technical Discussion 23 08-01-2019 06:17 AM
What is the correct gear to speed ratio? Ankur Vashishtha BMW G310R General Discussions 40 07-02-2019 10:46 PM
Gear indicator potentiometer trouble Cees Klumper 2017+ BMW G310 R / GS Complaints, Issues And Problems 5 02-01-2019 02:08 PM
Cold Start Issue in Chinese market whatever 2017+ BMW G310 R / GS Complaints, Issues And Problems 11 12-15-2018 01:54 AM
Riding Gear LiquidCool Parts and Accessories 14 02-22-2017 01:37 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome