I have problem about Engine to my G310R, Please help me - BMW G310 R/GS Forum
 28Likes
Reply
 
LinkBack Thread Tools
post #1 of 38 (permalink) Old 09-24-2017, 11:49 AM Thread Starter
Junior Member
 
Join Date: Sep 2017
Location: Thailand
Posts: 19
I have problem about Engine to my G310R, Please help me

Hi I'm Best from Thailand
I got G310R last week and today I begin ride it but I fine some problem at the screen panel.
The General Warning Light & The Engine Electronics Symbol apper (Not flashes) after I ride about 11 Km.
I stop my Ride for check it's disappear in a moment.
I continue ride, it's appear again.
And sometime ABS Light appear also.
But no engine problem occur , I still ride to 100 km.

Anyone ever seen like this before?
Attached Thumbnails
Click image for larger version

Name:	17-09-24-15-02-03-703_deco.jpg
Views:	383
Size:	154.7 KB
ID:	1385  
bestjita is offline  
Sponsored Links
Advertisement
 
post #2 of 38 (permalink) Old 09-24-2017, 01:14 PM
Senior Member
 
Join Date: Jun 2017
Location: Netherlands
Posts: 766
Garage
Dear bestjita,
If It is a new G310, go back to your BMW dealer and let them solve this problem.
If the bike runs good It might be a software problem.
Hope this Will help
angiedave, cfaircraft and bestjita like this.
Bas310 is offline  
post #3 of 38 (permalink) Old 09-24-2017, 02:06 PM
Senior Member
 
WoodWorks's Avatar
 
Join Date: Dec 2016
Location: Ashland, OR, USA
Posts: 245
What BAS310 said. Get that thing back to the dealer. If it's just a software glitch, it'll probably be quickly resolved. If it's something more serious, you donít want to potentially be making it any worse.
angiedave and bestjita like this.
WoodWorks is online now  
post #4 of 38 (permalink) Old 09-26-2017, 11:58 AM Thread Starter
Junior Member
 
Join Date: Sep 2017
Location: Thailand
Posts: 19
Now I found that!!!
Radiator Fan not operate.
In normally Fan will opreate if Temp. rise up to 104 Degree celsius.
But in my case Fan not operate. (T^T)
This Weekend may be I will go back to Dealer for claim it.
bestjita is offline  
post #5 of 38 (permalink) Old 09-26-2017, 12:36 PM
Senior Member
 
Join Date: Jul 2017
Location: Escondido, Caifornia ( 36 Miles north of San Diego )
Posts: 152
Sounds like a trip to the dealer is mandatory. I would not let any of these types of issues continue any more than a couple days without the dealer being involved. The warranty is there for this type of problem, and it honestly sounds like an electronics failure of some sort ( EMS, Instrument cluster, ECM ) etc. Don't wait until a major problem develops to get it into a dealer or they may have the opinion that negligence played a part in the failure.
angiedave and bestjita like this.
Zente is offline  
post #6 of 38 (permalink) Old 09-26-2017, 05:27 PM
Member
 
Join Date: Jun 2017
Posts: 46
From the manual...

Engine in emergency-operation mode z

(General warning light lights up yellow. The engine electronics symbol appears on the display.)

Unusual handling when engine is in emergency operat- ing mode
Accident hazard
Adapt riding style: avoid rapid acceleration and passing maneuvers.

Possible cause:
The engine control unit has diagnosed a fault which impairs the engine performance or throttle response. The engine is run- ning in the emergency-operation mode. In exceptional cases, the engine stops and can no longer be started.
Have the malfunction corrected as soon as possible at an authorized service facility, preferably an authorized
BMW Motorrad Retailer.

It is possible to continue riding, however the engine performance and engine speed range may be impaired and not func- tion as normal.
WoodWorks, Bas310 and bestjita like this.
MandatedMotorvation is offline  
post #7 of 38 (permalink) Old 09-28-2017, 01:54 PM
Senior Member
 
Join Date: Jun 2017
Location: Netherlands
Posts: 766
Garage
What did the dealer say ?
I'm quite interested how he wil take care of your problem.
Bas310 is offline  
post #8 of 38 (permalink) Old 09-28-2017, 02:08 PM
Senior Member
 
Join Date: Jun 2017
Location: Stoke on Trent, UK
Posts: 196
Quote:
Originally Posted by bestjita View Post
Hi I'm Best from Thailand
I got G310R last week and today I begin ride it but I fine some problem at the screen panel.
The General Warning Light & The Engine Electronics Symbol apper (Not flashes) after I ride about 11 Km.
I stop my Ride for check it's disappear in a moment.
I continue ride, it's appear again.
And sometime ABS Light appear also.
But no engine problem occur , I still ride to 100 km.

Anyone ever seen like this before?
You can get these problems when the battery connections are not tight.
G0MYW and NIKOS like this.
Glencoeman is offline  
post #9 of 38 (permalink) Old 09-28-2017, 11:03 PM Thread Starter
Junior Member
 
Join Date: Sep 2017
Location: Thailand
Posts: 19
Quote:
Originally Posted by Glencoeman View Post
You can get these problems when the battery connections are not tight.
Yes !!! That's it
Today I check battery connection, It's loosen.
After I thghten it, My G310 can run normally.

Thank You very much!!!
bestjita is offline  
post #10 of 38 (permalink) Old 09-29-2017, 05:01 AM
Senior Member
 
Join Date: Jun 2017
Location: Stoke on Trent, UK
Posts: 196
Quote:
Originally Posted by bestjita View Post
Yes !!! That's it
Today I check battery connection, It's loosen.
After I thghten it, My G310 can run normally.

Thank You very much!!!
Glad it is good now. It seems that modern bike electrics are much more sensitive to bad connections. Always look for simple solutions before you do anything else.
Glencoeman is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Tutorial: Engine Oil Change heap Service And Maintenance 43 04-16-2019 12:09 PM
Feedback from First G310R Owners G310Admin G310R News 5 05-30-2018 03:03 PM
BMW G310R vs KTM Duke 390 G310R News G310R News 15 06-14-2017 08:30 PM
Another Look At The G310R G310R News G310R News 19 12-07-2016 12:31 PM
G310R First Look!! G310R News G310R News 2 11-17-2015 12:30 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome