Bike completely dead, no clue what's wrong - Page 2 - BMW G310 R/GS Forum
 8Likes
Reply
 
LinkBack Thread Tools
post #11 of 65 (permalink) Old 10-04-2018, 05:50 PM
Pen
Junior Member
 
Join Date: Jan 2018
Posts: 18
Update,


Just got a phone call saying it's all done. Yay, but I'm definitely going to check the bike all over before getting on it. 3 weeks the repair took, not too bad bad would had loved to have known that from day 1.
Pen is offline  
Sponsored Links
Advertisement
 
post #12 of 65 (permalink) Old 10-07-2018, 04:37 PM
Pen
Junior Member
 
Join Date: Jan 2018
Posts: 18
Bike's back, 3 weeks repair, rides nice, happy to have it again after 3 weeks of nothing. The place I took it to did a good job, apart from the communication.
Pen is offline  
post #13 of 65 (permalink) Old 10-07-2018, 05:08 PM
Senior Member
 
Tripod's Avatar
 
Join Date: Aug 2018
Location: Las Cruces, NM
Posts: 252
Yay!!!
Tripod is offline  
post #14 of 65 (permalink) Old 10-10-2018, 09:41 AM
Junior Member
 
Join Date: Sep 2018
Posts: 13
Pen
Glad to hear your back in business. The last communication I received said that the part will not be available until "Maybe" the end of November. I live in the US so it seems it is even harder to get parts over here. I'm going to have a serious talk with my BMW rep next week. I'm at the point where I want them to just buy back the bike for what I paid for it. The 750GS are starting to hit the market over here in the US and I think it's time to move on to a BMW that is actually made in Germany. And maybe, just maybe if something happens to that one, they will be able to get parts for it. There seems to be some kind of disconnect between India and Germany. BMW says that Germany does not have the part for my bike and they are waiting to receive it. I know Fed-ex can move parts around the world in a couple of days, so I really don't get whats going on. I hope everything works out for you! Maybe I will get my bike back, I guess I will have to wait and see what happens.
Timekeeper1968 is offline  
post #15 of 65 (permalink) Old 10-10-2018, 06:35 PM
Member
 
DRTDVL's Avatar
 
Join Date: Jun 2018
Posts: 94
I just got my bike back from our local dealer as I had a strange problem where the battery was flat (looks like the lights were left on) and after jump starting it and riding it 20 - 25min into town. The bike wouldn't start again, you could hear the fuel pump but nothing else ticking over. After a few tries, the engine light and teh battery light came on.

They picked the bike up, found the battery was dead flat again and after 2 days investigating they couldn't find anything wrong and the bike was starting up as normal.

I've had it for 2 days now and now no problems yet....

They did mention that they had another g310 in with a dead stator and it's a very odd part to die, so they wanted to run extra tests on it, but found nothing - no faults, logs, nothing.
DRTDVL is offline  
post #16 of 65 (permalink) Old 10-10-2018, 10:07 PM
Pen
Junior Member
 
Join Date: Jan 2018
Posts: 18
Hi Timekeeper, I know it is extremely frustrating, I myself got to the stage where I felt like saying "stuff it, I'll order the part myself and do the repair" even though I wouldn't have a clue how, I felt it would be done in a few days tops, part ordered and received straight to me within days. Screw the warranty right, whats the point of having a bike you paid for (paying for) that can't be used. Also hard when you have no other bike to ride. Thought I was just share some of my frustrations so you know you are not alone. I'd do what you suggested, get in touch with a BMW rep and see what they can do, this customer service is very very bad (the repair shop in the end represents BMW) and will push people to other brands.


DRTDVL,


My bike's rear light (G310R) went out entirely months before my Stator died, I pulled over at that time, re-seated the connections under the seat and that fixed it, or so I thought until the Stator died, which happened exactly how you described it, flat battery while riding, just after riding, lights still on but very dim, electricity sound going through the bike when ignition pushed but bike stays dead. I wouldn't ride your bike at all, too dangerous, until the shop you take it to repairs it.
Pen is offline  
post #17 of 65 (permalink) Old 10-10-2018, 11:37 PM
Member
 
DRTDVL's Avatar
 
Join Date: Jun 2018
Posts: 94
Timekeeper, i would be requesting a loan bike at that stage. It's my only practical form of transport to work, so unless I wanted to drive my car in, pay for parking and spend $120+ per week over the $18 per week I currently pay (free bike parking at work)...

Pen - I had a flat battery because the key was left on, I suspect - I can't remember turning on, but I was tired and sleepy when I did try and start the bike. they did say it sounded like what you have said but they can't fault it again. I've had it for 2 days now and nothing has gone wrong so far, as they can't fault it there is nothing more they can do.
DRTDVL is offline  
post #18 of 65 (permalink) Old 10-12-2018, 12:38 PM
Junior Member
 
Join Date: Sep 2018
Posts: 13
Hi DRTDVL,


Sorry to say, but the US market will not give you a loaner bike. I am at a disadvantage being that my bike was not brought to the dealer where a bought it, so sad to say I do not have any leverage and they feel no obligation to me. I asked BMW customer service for a loaner bike and they said no. I will be calling them next week to see what is going on. That will mark 3 weeks since a received any update from them and mark 6 weeks without my bike. :-(
Timekeeper1968 is offline  
post #19 of 65 (permalink) Old 10-12-2018, 02:09 PM
Junior Member
 
Join Date: Sep 2018
Posts: 15
Looks like I have a similar problem. 2018 G310GS with just over 500 miles in the US. Starter making a whirring noise that it never had previously but would start the bike. Stalled later after a short ride and would not start again, starter would not crank, battery light lit on dash.

Dealer told me to expect a prolonged repair time period since no spare parts are on hand. Brand new bike, perfect riding weather... very disappointed.
Serrated is offline  
post #20 of 65 (permalink) Old 10-12-2018, 10:42 PM
Super Moderator
 
Cees Klumper's Avatar
 
Join Date: Mar 2018
Location: Marina del Rey, California
Posts: 363
Garage
Send a message via Skype™ to Cees Klumper
Boy to think I bought my R as a backup when my BMW C650 GT with under 2,000 miles started acting up (dealer did not tighten battery connection, defective cam chain tensioner). Seems like I should now be worried about both! Luckily I just picked up my third and final bike, a 1976 (!) Yamaha XS650. That just might turn out to be the most reliable of the trio ...

2018 G 310 R, 2016 C 650 Sport and 1976 (!) Yamaha XS650
Cees Klumper is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
G310GS Adventure kit - FAQs JMo Rally Raid Products 12 02-06-2019 12:14 PM
Feedback from First G310R Owners G310Admin G310R News 5 05-30-2018 04:03 PM
G310GS Adventure: smaller bike, bigger adventure (North America 2018) JMo Rally Raid Products 7 04-22-2018 01:01 AM
Rally Raid Video - A Must See For GS Owners MOTOMAN BMW G310GS Pictures And Videos 4 03-13-2018 12:22 PM
2018 bmw 310 r Dani1959 BMW G310 Owners Registry And Check In Area 9 02-24-2018 09:30 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome