BMW G310 R/GS Forum banner

21 - 40 of 65 Posts

·
Registered
Joined
·
13 Posts
UPDATE:


Still no bike.:frown2: The dealer who has my bike sent me an email and said that the part is due for release today 10/24. So I don't know how long it will be for the part to come in. BMW had said that the parts were not due until November so I guess I will see who is right. The sad part is, I decided to go down to the dealer to see my bike and what a mistake that was. The dealer is not the one I bought the bike from or where I get service. This place has a 2 1/2 star rating review and the place was a Joke. I was there for 20min and nobody came up to us to help us out. I found where my bike was and it was 4 feet from the open garage door. The bike was covered in dust and dirt and the tank cover was off sitting on the floor on a 2nd floor wooden platform. Needless to say, it was a little disappointing. At this point I am at a loss for words with this whole experience. I am curious to see what type of compensation BMW will offer if anything after this is all over.
 

·
Registered
Joined
·
1 Posts
Attempted to start 2018 310GS this morning. Has 155 miles on it. It cranked and just kept cranking I attempted to shut it down with the kill switch (no dice) tried shutting down by turning key off (no dice). It essentially kept cranking until the battery died. Now the battery is roached. Has anyone else experienced this? I've had plenty of bikes and this is a first.
 

·
Registered
Joined
·
10 Posts
Wondering if anybody has the part # for that Stator for a 2018 G310 GS?
I was thinking it might be a good idea to just carry one around in case
my decides to puke out & then hopefully I don't have to wait for weeks to

get it fixed.
I tried looking online at a parts fiche/diagram & I don't see the stator listed --
though could be looking in the wrong area (was looking in the electrical/alternator
section).
Thanks very much!
 

·
Registered
Joined
·
10 Posts
Thanks --
though your links only go to main site.

I'm thinking it's the voltage regulator, because there is not 'stater' or 'stator' listed separately --

so probably just going to order the voltage regulator tomorrow.
Thanks again.
 

·
Registered
Joined
·
155 Posts
Both listings have the same part number on the links above. The P/N supersedes the previous one. While the VR could cause no charging, the information on this site and my own experience indicate the stator is the culprit. Hopefully the new one solved the problem. VR is around $150.00 US while I didn't find a price on stator, but would expect it to be a lot more.



JRG it sounds like a relay is stuck, but an '18 should still be under warranty. Call roadside assistance or carry it on you own to your dealer and let them sort it out and give you a new battery while at it. This is not a commonly reported problem on this bike.
 

·
Registered
Joined
·
10 Posts
Yikes if it's going to require the entire alternator. I had also looked that up & it's $400+

and not really excited about laying that out --



but the challenge is going to be 2 trips I have planned into the boonies of Utah & Colorado, plus a 3rd quick trip through South Carolina --



and not really wanting to get completely stranded with no bike because there's no parts.


I'm going to call my dealer tomorrow & see what they have been repairing/replacing in their service department.


Thanks for all of the info everybody! Greatly appreciate it.
 

·
Super Moderator
Joined
·
931 Posts
Under warrantee you shouldn't need to pay a cent. As mentioned in previous posts, make sure you get the bike thoroughly checked about a month before warrantee runs out. Find out when your warrantee runs out and set yourself a reminder!
 

·
Registered
Joined
·
10 Posts
Yeah -- I get that about not supposed to be paying, but I don't like being stuck.
Good point on the warranty period -- I need to check that out.


I actually only have 14 miles on the bike & JUST got it back 2 days ago after having it spend the winter at my local shop (great local mechanic) who tricked it all out for me for off-road --

and I have ridden it a total of 1/2 of a mile so far (we still have

snow on the ground here & it was a COLD ride 2 nights ago).


So -- will be calling the dealer first thing in the morning.


Thanks much & I was in Australia for the month of September
riding & LOVED your beautiful country & the people.
 

·
Registered
Joined
·
14 Posts
My second G310gs, 15,000ks, 12 months old, this bike has been fabulous handling everything I can toss at it.

Yesterday riding the freeway the abs light comes on, about a minute later the battery light comes on, a minute later the engine dies. Lights, horn, blinkers working but It won’t crank over.

About 15 mins later I try again, the engine cranks a few revs but that was all. Bike goes home on trailer.

Checked the battery when I got home, 11.4V. Put the battery on charge and a few hours later it’s holding 12.7V. Back in the bike the 310 starts first go. When I checked the voltage while the bike was running with high beam, voltage drops to 12.6V instead of an expected rise to 13+V. Seemed like the bike wasn’t charging. Took it down to the boys at Rock and they confirmed that there was no charge. Bike was running fine as long as it had a charged battery.

Interesting to find this problem popping up around the forums. Sure hope it can be resolved quickly and on warranty. We’ll find out.
 

·
Registered
Joined
·
1 Posts
This exact scenario has left me stranded twice now on my r. Stator + regulator the first time with a two week wait for parts; bike’s back in the shop again this time stator + regulator + battery with no parts ETA after one week. Frustrating to have a bike in for electrics twice and three times for dripping coolant plus two tows in 6,600 miles. Love the way the bike rides but my patients is wearing thin for the mechanical issues.
 

·
Registered
Joined
·
30 Posts
This exact scenario has left me stranded twice now on my r. Stator + regulator the first time with a two week wait for parts; bike’s back in the shop again this time stator + regulator + battery with no parts ETA after one week. Frustrating to have a bike in for electrics twice and three times for dripping coolant plus two tows in 6,600 miles. Love the way the bike rides but my patients is wearing thin for the mechanical issues.
Your issue exactly the same to my gs, its only 3900km: stator n regulator replaced, 3 waterpump replaced.... Still waiting the part for the 3rd waterpump.... Been 3 weeks of waiting..... Totally LEMON 🙂
 

·
Super Moderator
Joined
·
931 Posts
Exact same thing happened to mine on April 17th and tomorrow makes 6 weeks in the shop. When I get it back I’m trading it in.
That's no good, let us know what they say the problem was. Did you have any hesitation or anything before it happened or was it sudden?
 

·
Registered
Joined
·
340 Posts
Exact same thing happened to mine on April 17th and tomorrow makes 6 weeks in the shop. When I get it back I’m trading it in.
That's no good, let us know what they say the problem was. Did you have any hesitation or anything before it happened or was it sudden?

I was on the Hwy and I noticed the ABS light came on. I thought hmm that’s strange. A few seconds later the battery light came on. Then came the sputtering and loss of power. When I went to put on the turn signal to get over to the shoulder they didn’t work either. Tried starting it and it was completely dead. Dealer came picked it up and had it 6 weeks already. They said the starter and the starter gear didn’t match up even though its the same part number so they are waiting for the part which is on back order and no estimated date to come in. I honestly loved this bike until this happened. It has been out globally since 2016 as a 2017 model and in the US since late 2017 as a 2018 model. There should be no reason there aren’t parts available and have people waiting over 6 weeks to get their bike back that they still are paying for with no loaner bike. The dealer even has a demo bike they should have scavenged the parts from. People aren’t beating down the doors to test ride the G310 R here especially since the GS310 came out. This whole experience with waiting this long for a part has left me scorned and salty. If something else happens I’m not willing to wait this long again for a warranty repair.
 

·
Registered
Joined
·
340 Posts
UPDATE: I got my bike back this past Saturday. Made 7 1/2 weeks I waited for it. Tomorrow going to do final numbers on a Yamaha. The wait time and lack of available parts to do repairs on a bike that’s been out worldwide since 2017 was enough to leave a bad taste for me.
 
21 - 40 of 65 Posts
Top