BMW G310 R/GS Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi all,

My bike has decided to not start anymore. :(

I have the following symptoms;

1. Can't hear the fuel pump priming.
2. Turns over but not firing.
3. Blows fuse #1 immediately.

I am assuming this is a pump/fuel delivery system problem.
Trying to see if anyone had the same issue and have any advice on how to proceed.


Thanks!

Vehicle registration plate Automotive mirror Automotive lighting Motor vehicle Automotive tire
Textile Grey Bag Webbing Auto part
 

·
Registered
G310GS 2018
Joined
·
666 Posts
Check the connection between fuel pump power feed and frame, and fuse 1 and frame. If the wire is conducting, you have a short circuit somewhere. Then search for the contact ponit and isolate the wire.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Check the connection between fuel pump power feed and frame, and fuse 1 and frame. If the wire is conducting, you have a short circuit somewhere. Then search for the contact ponit and isolate the wire.
Check the connection between fuel pump power feed and frame, and fuse 1 and frame. If the wire is conducting, you have a short circuit somewhere. Then search for the contact ponit and isolate the wire.
Thanks. Looks like there a some continuity on fuel pump feed. Bike supposed to go to the dealership at some point for an unrelated issue, so I'll let them sort this out rather than digging into the harness myself now.
 
1 - 3 of 3 Posts
Top