BMW G310 R/GS Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hello all!

Anyone have experience with the OEM heated grips? I’m thinking of getting them but wanted to see if anyone had an experience installing them.
 

·
Registered
G310 GS
Joined
·
33 Posts
My Oxford grips arrived yesterday and I want to mount them this weekend. I also installed them on my Tenere and they are the best I've ever had. If needed, they get pretty warm and are very good to set. The auto-switch-off works fine.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #8
The OEM ones are arriving this Tuesday for me. I’ll post ASAP.

the oxfords look awesome!
 

·
Registered
Joined
·
82 Posts
Took the bike out this morning on a short trip,loved wearing my summer gloves with the heated grips on,hands were toasty.....:cool:
 

·
Registered
Joined
·
10 Posts
Discussion Starter #10
Switch is in!

going to need to figure out where the relay goes behind the headlight but it’s going swimmingly so far.

14730
 

·
Registered
Joined
·
10 Posts
Discussion Starter #13
I did! Relay clips into the left body panel on the inside.

settings are actually quite impressive. Was worried that it was going to be hot and very hot, but the low setting does just enough on a cool morning and the high setting would be good for when it’s extra cold. Pretty happy with the OEM set.
 

·
Registered
Joined
·
2 Posts
I did! Relay clips into the left body panel on the inside.

settings are actually quite impressive. Was worried that it was going to be hot and very hot, but the low setting does just enough on a cool morning and the high setting would be good for when it’s extra cold. Pretty happy with the OEM set.
Where did you pull power from. On the OEM set that I received the power plug does not reach the only power point that I was able to find near the battery, is there something closer to the relay mounting spot?
 

·
Registered
Joined
·
209 Posts
Can't really help you, mine are not OEM.....All I know is where the Aux power outputs are....from searching the forum.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #19
The wires aren't long enough, I can send pictures if you like. I didn't think I would have to cut and extend the OEM kit to reach.
You do not need to cut or extend the wires at all. I’ll take pictures of where the relay is when I get to where I’ve stored the bike.
 
1 - 19 of 19 Posts
Top