BMW G310 R/GS Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
123 Posts
Discussion Starter #1 (Edited)
when I start engine in N gear is ok! when i start with 1 gear shift the bike don't start! the the motorcycle stand switch is ok! when i extend the stand the engine switch off...is a very strange problem, where is the clutch switch that check you are pulling the clutch?
?
 

·
Super Moderator
Joined
·
931 Posts
when I start engine in N gear is ok! when i start with 1 gear shift the bike don't start! the the motorcycle stand switch is ok! when i extend the stand the engine switch off...is a very strange problem, where is the clutch switch that check you are pulling the clutch?
?
This is by design, when you put the stand down in gear the engine will turn off regardless of clutch.

If the engine is turning off when the gear is in neutral there is something wrong.

Or is your problem that the engine will not turn on in gear when the stand is up? this shouldn't happen and something is probably wrong with the clutch switch, this can happen when fitting after market levers.
 

·
Registered
Joined
·
123 Posts
Discussion Starter #5
This is by design, when you put the stand down in gear the engine will turn off regardless of clutch.

If the engine is turning off when the gear is in neutral there is something wrong.

Or is your problem that the engine will not turn on in gear when the stand is up? this shouldn't happen and something is probably wrong with the clutch switch, this can happen when fitting after market levers.
yes I have after market levers the problem is the engine will not turn on in gear when the stand is up
 

·
Registered
Joined
·
75 Posts
Manually engage your clutch microswitch to see if that makes a difference.
Alternatively, you could short out the cables to it and check.
 

·
Super Moderator
Joined
·
931 Posts
yes I have after market levers the problem is the engine will not turn on in gear when the stand is up
OK, seems like the after market clutch lever is not engaging the clutch switch, quite a few other members have had this problem, you may need to bend out the switch just a little bit so that it engages when you pull the clutch.
 

·
Registered
Joined
·
123 Posts
Discussion Starter #9
I have used aftermarket levers for over 1 year without problems ... I feel the click, and sometimes it just doesn't work
 

·
Super Moderator
Joined
·
931 Posts
I have used aftermarket levers for over 1 year without problems ... I feel the click, and sometimes it just doesn't work
Do you always start in gear? or do you mostly start in neutral, and the problem only occurs when you start in gear. I know that I always start in neutral, and only start in gear about 3-6 times a year (after an unexplained stall :wink2:, or when I park in gear on an incline).

The aftermarket lever won't give you any problems if you start in neutral, but may give you problems if you try to start in gear, this is why after market levers can be dangerous if not fitted correctly, imagine stalling in traffic, and trying to start quickly in gear to get away from a truck that is coming up behind you.

Do you still have the original clutch lever? refit and see if the problem persists, that way you can eliminate one of the possibilities. If the problem persists with original clutch lever, take it to the dealer and get them to fix it under warranty.

The click of the switch seems to indicate that the lever is actuating the switch. the CRC marine that you sprayed into the switch might be causing the problem (don't mention this to the dealer when you take it in).
 

·
Registered
Joined
·
123 Posts
Discussion Starter #12
I start with the gear engaged only when the engine stalled, I used the Chinese levers for a year and a half without problems now with the gear engaged no longer starts, only at neutral, but this switch is defective? BMW know the problem?
 

·
Registered
Joined
·
123 Posts
Discussion Starter #13
yesterday the BMW salesman told me that he replaces the switch even though the warranty has expired for 2 months expired.
Very good, ordered the item not in stock
 

·
Registered
Joined
·
123 Posts
Discussion Starter #17
I'm waiting the spare part from 20 days!!!
is impossible to understand for a big brand as BMW!!!!!
 
1 - 17 of 17 Posts
Top