BMW G310 R/GS Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
169 Posts
Discussion Starter #1
Last week I have had a minor issue with the starter. It usually starts instantly when I press the ignition button, but lately it has been taking 1-1.5sec longer than usual to fire up. No misfires and the climate is still very warm. When it fires up it starts at very low RPM as if struggling. Is it anything to worry about or should I be concerned?
 

·
Premium Member
Joined
·
428 Posts
It does sound like there is something wrong; could be many things. Best would be to have a BMW dealer read the ECU for fault codes. Short of that, you might try pouring some injector cleaner into the fuel, and refueling at a different pump with the highest octane gas they have, see if that makes a difference. Another cheap and easy check is to put in a new spark plug.
 

·
Registered
Joined
·
106 Posts
Are you following the starting procedure thats dictated in the owners manual? Just because its warm temp you still need to use the same procedure as when the temp is cold imo
 

·
Super Moderator
Joined
·
931 Posts
Just to clarify, you are talking about the electrical starter motor taking longer to start after the button has been pressed, not the overall length to get the motor started. Check your voltage, otherwise there may be something wrong with your starter motor. Keep an eye on it, see if it changes, maybe notify your dealer, see what they say and possibly get them to get a replacement on stock should yours need replacing the next time you go in for a service.
 

·
Registered
Joined
·
169 Posts
Discussion Starter #6
Checked the bike thoroughly this morning before going to work, there was a battery cable that seemed to me a bit loose and tightened it. It fired up like normal, maybe that was it but I will have it in mind for the rest of the week until the gas tank dries out and I refill it with 100-octane fuel. If that doesn't do it, I will probably go on to switch out the spark plugs and afterwards check the battery with a voltmeter. Trying to exhaust as many options as possible before having to travel off the island to the dealer as there are many financial and logistics challenges involved.

Thanks for the replies.
 

·
Registered
Joined
·
169 Posts
Discussion Starter #8
Do not waste your money on 100 octane fuel it will make no difference nor solve your problem, it will just cost you more to fill up.
I know, it's just that this is Greece and it is known for gas stations to fill inflate their gas with various liquids to increase their volume while also lowering its quality. 100-octane is just a small step into avoiding that and making sure it's not the gas that's the problem; a one time thing for troubleshooting.


** Quick Update ** I let it dry and then refilled it, I didn't see any difference; afterwards I left it for 2 days in the courtyard to see if there's any discharge issue or something else regarding the battery. I used my car in the meantime and after I tried to turn on the bike today it misfired 3 times, which on the 4th it barely turned on while I was using the throttle as well. I switched it off after commuting halfway to work and turning it on again and it fired instantly. I have arranged to go to the local automotive electrician shop. He said it's most probably the battery but will check out all cases. I called the dealer afterwards to let him know, he said he would have been able to cover it in the warranty, however I would need to be up there at the dealer. I told him about the financial/logistics inconvenience and he said there should be no problem with voiding the warranty, just that I will have to cover the expenses of a new battery (if that's the case) which seems fair.

I will update further tomorrow.
 

·
Premium Member
Joined
·
428 Posts
It does start to sound like it is the battery or battery connections. The shop should also check the charging voltage. Good luck with the repair, I suppose the BMW Roadside Assistance is not included in your warranty because of where you live?
 

·
Registered
Joined
·
252 Posts
I checked my battery connections the day I purchased my GS after I brought it home. They were a little loose. I have yet to purchase a vehicle of any kind & found the battery connections tight. This is a worthwhile (& very easy) check...
 

·
Registered
Joined
·
169 Posts
Discussion Starter #11
Didn't update yesterday due to insufficient time and was a tad tired.

So everything went well. I went to the local automotive electrician and we tested the voltage which was a meager ~9.2V after a 30minute ride to get there. He told me, and I quote, "****, how did your bike even start?". We replaced it with a MotoBatt 10Ah (MBTX9U). I called the dealer before agreeing to the change so they can discuss the specs, the technician and the electrician both came into agreement within 15 sec of their phone exchange. Technician told me, once again, that the warranty is not going to be broken and that I should ride confidently as the new battery is slightly stronger than the previous as well.

Day 1 today and everything went smoothly without hiccups. Didn't cost me much either so I'm rather pleasant with this!
 

·
Registered
Joined
·
159 Posts
Ligkonakos,

Don't want to rain on your parade, but have you checked if the alternator is charging the battery correctly. Remember that me and Zente (I think) had to have our alternators, batteries*and voltage regulator replaced as they were defective. On warranty, naturally

RobertB
 

·
Registered
Joined
·
169 Posts
Discussion Starter #14
Ligkonakos,

Don't want to rain on your parade, but have you checked if the alternator is charging the battery correctly. Remember that me and Zente (I think) had to have our alternators, batteries*and voltage regulator replaced as they were defective. On warranty, naturally

RobertB
The electrician didn't check it as the old battery was not charging to max theoretical capacity even with the external charger, but he didn't rule it out either. He told me to call him in 1 week time to check if everything is okay, which currently is perfect. Thanks for the concern!
 
1 - 14 of 14 Posts
Top